PRODA API Changelog

Unit & Property Variable Updates

New variables added:

  • in_place_rent_pa
  • loan_provider
  • property_market

Existing variables modified:

  • unit_street
  • unit_street_number
  • unit_postcode
  • unit_city
  • unit_region
  • unit_country

New fields

We have added a new rentrolls field to the file details endpoint.

We have added a new originalFileId field to the list files endpoint.

We have changed the meaning of the originalFileName field in the list files endpoint. It now refers to the name of the file that was originally uploaded by the user, corresponding to the originalFileId field. We have added a new fileName field with the name of the current file.

Changes to column names and new variables

We have made several updates to our data schema, including changes to column names for clarity and the addition of new variables.

  • actual_lettable_area_sqm: The name has been changed from Actual Lettable Area to Lettable Area.
  • contracted_lettable_area_sqm: The name has been changed from Lettable Area to Contract Lettable Area.
  • privacy_level: New variable.
  • payer_type: New variable.

File details endpoint

We have added a new file details endpoint.

List files endpoint

We have added a new list files endpoint.

FLOAT -> INT

We are planning on changing the column type of some variables from FLOAT to INT. We said we would not change column types, so this is technically a breaking change. However, these variables were already integers. The JSON serialisation will not change. We would like to make this change to improve consistency and performance. We would like to skip the usual deprecation process to avoid awkward variable names and creating more work for you with repeated renamings on our end.

If you think you would be negatively affected by this change, please reach out to us. We have notified customers by email as well.

These are the variables that we are proposing to change:

  • parking_spaces
  • excel_row_index
  • unit_count
  • rent_payment_day
  • rentroll_id
  • parking_and_
  • lettable_area_unit_count
  • bicycle_parking_spaces
  • proda_portfolio_id
  • extraction_id
  • dnb_company_hierarchy_level
  • dnb_employee_count
  • dnb_company_risk_indicator
  • rent_free_outstanding_months
  • extension_options_count
  • occupied_unit_count
  • vacant_unit_count
  • non_revenue_unit_count
  • occupied_unit_count_excl_non_revenue_units
  • vacant_unit_count_excl_non_revenue_units
  • catella_parking_spaces

First INT columns

To maintain a more consistent naming convention across our API, we are updating the following variable names.

The new variables are the first to have columnType: INT. This column type has been documented for a long time, but these are the first variables to actually use it. If you're not handling this column type yet, you should start now.

Variable additions:

  • proda_property_id
  • proda_project_id

Variable deprecations:

  • property_id - use proda_property_id instead
  • project_id - use proda_project_id instead

Variable changes:

  • operating_expense_and_heating_income_fixed_pm - Name change only. This variable was already deprecated and will be removed soon.
  • operating_expense_and_heating_income_pm - Name change only. This variable was already deprecated and will be removed soon.

Track Changes

Initial public preview of a new Track Changes endpoint. This enables API access to algorithmic Track Changes variables like "Reason for Rent Change".

This is an alpha release. The endpoint is subject to change without notice.

If this seems useful to you or if you have suggestions to make it even more useful, please let us know.